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Preface

In order to be useful for everybody who might want to do a translation of Open Rails, regardless of their
experience with programming, this tutorial will cover the basics as well as some advanced features and
"best practices".

As you might know, Open Rails is an open source project, and the code is hosted in a Git repository at
https://github.com/openrails/openrails . Anybody may download it from there either directly or by
using a Git client (more on that later).

Getting Started

In order to translate Open Rails, you will have to download and change (some of) the source files. With
the proper two (freeware) applications installed, this usually is not a problem. But first, let’s get them
set up.

Code Management - GitHub Desktop
The best way to download the code so you can work on it and submit your work is by using a Git client.


https://github.com/openrails/openrails

If you are already comfortable with a Git client of your choice, you can simply fork the official repository
at GitHub, check out a local copy and skip to the next section.

If you do not know how to work with Git, use Maintaining translations with GitHub Desktop?*

Translation Management - Poedit
When you're done setting up your local fork of the official repository, it's time to install the second
program you will need in order to translate ORTS: Poedit.

Download Poedit from here: http://Poedit.net/

When the download has finished, simply install it to your preferred location on your local drive, leaving
any other options at their default values.

Translation Process

When the installation and the download processes are done, you're done with the preparations and can
head off to actually translating.

Folders and Files

The files that contain ORTS' translation data are located in the folder
<WhereverYouSavedTheCodeTo>\openrails\Source\Locales\<PartOfTheProgram>

<PartOfThePrOgram> iS another |eVE| Of SUb-fOlderS, Dpenrails » Source » Locales » Menu
which contains the actual translation files for the different

sy

Mame

li] cspo

[ ] da.po

[ ] de.po

[ ] espo

|| frpo

[ ] hupo

[ ] it.peo

[ ] Menu.pot
[ ] pt-BR.po
[l ] pt-PT.po
| gps-ploc.po
[ ] rupo

[ ] zh-CM.po

! This can be downloaded from https://static.openrails.org/files/Maintaining-translations-with-GitHub-
Desktop.pdf



http://poedit.net/
https://static.openrails.org/files/Maintaining-translations-with-GitHub-Desktop.pdf
https://static.openrails.org/files/Maintaining-translations-with-GitHub-Desktop.pdf

parts of the program. These are the *.po files, e.g. “it” for Italian, “de-at” for Austrian German?.

Adding a Language
If your language is not included already, then use the template *.pot to create an initial version as
follows.

First, open Poedit using the shortcut the installer should have created on your desktop. Click the first
option, "Create new translation from POT template":

File Help

r Welcome to Poedit

E Version 3.5.2

Create new
Create new tra nzlat'ﬁn from POT ternplate.

(+)

Browse files
Open and edit translation files.

Translate WordPress theme or plug-in
Edit WordPress translations over FTP or locally.

Translate cloud project
Collaborate with other people online,

© @ U

With the Contrib folder as an example, in the pop-up window then opened navigate to
"<WhereverYouSavedTheCode>\openrails\Source\Locales\Contrib" and double-click on
"Contrib.pot".

2 For a full list of language codes, see
https://gist.github.com/eddieoz/63d839c8a20ef508cfa4fa9562632a21



https://gist.github.com/eddieoz/63d839c8a20ef508cfa4fa9562632a21

Poedit will load the file. If it throws any error or warning messages at you (usually about "the \r escape
sequence"), simply click OK and ignore it.

Once the file has been loaded, Poedit will display a pop-up window asking you to specify the language to
which you are going to translate. Use the drop-down list to select your language, e.g.:

Translation Language >

Language of the translation:

[Eszeront] v
Cancel

After clicking OK, immediately save the file to the folder (e.g. "Locales/Contrib/" (or, for other
translation files, to the proper folder) KEEPING THE FILENAME Poedit gave it. Ignore any errors that
might be mentioned - let the people deal with them who produced them ;)

| en_GB.po (unsaved) (modified) - Poedit — O x

File Edit View Translation Go Help
New... Ctrl+MN
New from POT/PQ file...

translate Upgrade to Pro [:[I

New WordPress translafion... Translation — English (United Kingdorn)

5 PRE-TRANSLATION x
Open... Ctrl+0
Open Recent > Pre-translate all items at once and focus on
making corrections, instead of translating them
Open cloud translation... one by one.
) ) n simulato...
Start window Ctrl+Shift+1
Catalogues manager Pre-translate | Mot interested
Save Ctrl+5
Suggestions Terminol
Save as... * v = logy
. 0]15
Compile to MO... ! EI Activity Editor
Export to HTML... Ctrl+1 - 95% - transisted by € Deepl
Export to Excel...
Rl 9 out of 10 online suggestions |eft.
Import from Excel... Remove this limitation

Check for updates...
License...

Settings...
Needs work (@

Exit

Add comment

Translated: 0 of 451 (0 %) » Remaining: 451

Repeat this process for each of the folders in Source/Locales/

Each folder applies to part of the core product except the Contrib folder which contains translations for
all the contributed programs together.

When that is all set-up, you have translation files without translations - not that good, of course. So, now
to the tricky part, actually getting a translation done.



Translating Text
Use File > Open in Poedit to load a *.po file and see the original text (in US English) in the left-hand
column and any translations in the right-hand column.

To edit a translation, just select the row in the top table and edit the bottom pane.

As with most editors, changes are saved as you make them, but not saved to file until you use File > Save
or try to close the Window.

Interpreting, how Poedit Assists You

In order to get a good translation done, it’s often necessary to keep track of strings that are not
translated spot-on yet. And altogether, with sometimes a few hundreds of strings in one PO file, it can
be hard to keep a good overview. But Poedit does a good job in assisting you, if you know what it does.

If you are not sure on how to translate a certain string, translate it as far as possible and while it is still
highlighted in the list, click on the "Needs work" button in the bar of the Translation pane. The text of
that certain string will now change to orange to indicate it’s not translated fully yet.

In order to get a brief overview of your progress, look at the very bottom left of the Poedit window.
There the program shows you the percent of the current file you have already translated, how many
records remain, and so on.

Keyboard Shortcuts
Clicking each and every list entry, then clicking inside the translation box and entering the actual text in
the non-English language is nice. You can, however, speed up the process a bit.

Best thing to do is start outright with the first list entry and work sequentially to the last one. That is
facilitated using keyboard shortcuts instead of clicking each next entry with the mouse.

CTRL + ENTER will highlight the next not-yet-translated list entry for translation (this includes those
marked "Needs work"). Simply type away, and press CTRL + ENTER again when you’re done to bring up
the next string.

CTRL + B inserts the source text into the translation field. This can be useful if the source contains
formatting tags such as {0} or /n, which need to be kept in the translation. You can simply select the
English parts as in any text editor and replace them appropriately. Sadly, there is no indication what the
{0} markers stand for in any specific string (they are used to insert additional text while ORTS executed,
i.e. at run time). Usually, you can just guess, if it isn’t clear (see Chapter 6. Getting Help with Ambiguous
/ Unclear Strings).

CTRL + B also is useful when you absolutely don’t know how to translate a string. Simply insert the
original, and mark the list entry as “Needs work”. This will later indicate to you that you already tried to

translate that string, but couldn’t.

CTRL + U is a toggle to mark and unmark a translation as “Needs work”.



Preparing to Submit
When you're done with the translation in a particular folder of the "Locales" folder, move on to the
next one until you're done with all of the folders.

Then generate the *.dll files from which ORTS gets its translations. Do this from the command line by
running the batch file Source/Locales/Update.bat. Here is some of the output:

nntitiratinnc - - — —_—

or during execution: Invalid escape sequence '?' in string: '[¢?rl-R\?Reldad ??& réd?en !I1I]°
rated OK

Template file "C:\de cjakeman\openrails\Source\locales\Menu\Menu.pot' generated

Generated OK

This process generates files such as
openrails\Program\<language code>\RunActivity.Messages.resources.dll

for all the language codes and all the program components.

If you copy these files to the corresponding folders of your current Open Rails installation, then you can
run Open Rails and view your translations “in game”.

Space Restrictions
Please check for translations which are too long for the space provided in the game.

If a good translation cannot be fitted into the space that the program provides, please ask for the
program to be changed to provide more space. Clarity is preferred over neat presentation.

Updating an Existing Translation
As ORTS progresses, so does its base of localizable strings, and an update of the translations will be
necessary. Poedit also helps you with that.

We assume that you have used GitHub to update your repository with the latest version of the
“upstream/master” branch.

This will update the *.pot files and your task is to update the *.po files for your language to match.

Back in Poedit, and for each folder in the Locales folder, do the following:



Use File > Open to load the *.po file and note the statistics in the bottom left corner, such as:

Translation

Editeur Agtivité

Translated: 441 of 446 (93 %) » Remnaining: 5

Then use “Translation > Update from POT file . . . “ to pick the *.pot file for the folder.

i e Bt b mm e g E W e A E e

| fr.po (modified) - Poedit
File Edit View | Translation Ge Help
= = Source Text ¥

Update from source code
Update from POT file..,

Sync with Crowdin

Source text — |

rmenustrip
statusStrip

toolStripButton Pre-translate...
Form1

label7 Validate translations
mouse-right cli Statictics

Select event col
Remowve same-as-source translations

events Purge deleted translations

Properties... Alt+Enter

Activity Editor
Ignore any errors that might be mentioned - let the people deal with them who produced them ;)
Look again at the values in the bottom left to see if any have been changed by this update.

If nothing has changed, then exit the file, preferably without saving. Otherwise, find the changes and
translate them.

You can use “View > Group by context” to bring missing entries and those that need work to the top of
the table:



| fr.pe (modified) - Poedit

File Edit View Translation Go Help

= B Show string |D |

+~  Show warnings

Source Customise warnings...

menust .

ctatusSy @ oort by file order

toolStrip Sort by source

Form1 Sort by translation

label7 5 it

Mouse-| LI #

~  Entries with errors first

Select ac » Untranslated entries first

Show suggestions tab Ctrl+5Shift+T
Ac;ivit; Show terminelogy tab Ctri+T
Show code cccurrences
Source tex
.. ) Show sidebar Alt+Ctrl+5
Activity Edit

" Show status bar

Getting Help with Ambiguous / Unclear Strings

As already mentioned, you will not be able to translate each and every string flawlessly without help and
explanations. Some may be ambiguous, and most lack information about the context in which they are
being used. But there are several methods to get around this.

The fastest, though not most straightforward method is to look at the source code of ORTS. This is,
however, only recommended for people who have a fair bit of experience with programming (C# is the
language used most extensively in ORTS). Highlight the string you're having problems with in the table,
then use “View > Show code occurrences”



File Edit
=

« Source’

menust
ctatusst
toolStrip
Form1
label7
mouse-|
Select &
Select ac
Show ey
Show ey
Activity
Source texi

Select event

| fr.po (modified) - Poedit

View Translation Go Help

'

'

Show string |0 !
Show warnings

Customise warnings..

Sort by file order
Sort by source

Sort by translation

Group by context
Entries with errors first

Untranslated entries first

Show suggestions tab Ctrl+Shift+T
Show terminclogy tab Ctrl+T
Show code cccurrences

by

Show sidebar Alt+Ctrl+5
Show status bar

to pop up a window with the source code:

. | Code Occurrences

- O X

|.J.J'ICuntrib,-"Track\l"iewen"[}rawinngrawCulms.r_':Z‘I8 ~ | 1 code occurrence

itemColor.MakeIntolUserPreference(preferenceChanger, "rosdcrossing”, <
TrackViewsr.catalog.GetString{"Select roed crossing color”));
itemColors.RoadCrossing = itemColor;

itemColor = new ColorlWithHighlights(Color.Purple, 48);

itemColor.MakeIntolUserPreference(preferenceChanger, "speedpost”,
TrackWiewsr.catalog.GetString("Select spesdpost color™));

itemColors.5peedpost = itemColor; .

itemColor = new ColorlWithHighlights(Color.DarkGray, 4@);
itemColor.MakeIntolUserPreference(preferenceChanger, "event”,
TrackWiewer.catalog.GetString("Select event color™));

itemColors.Event = itemColor;

itemColor = new ColorkWithHighlights(Color.Blue, 48);
itemColors.CandidateNode = itemColor;

itemColor = new ColorlWithHighlights(Color.Purple, 48);
itemColors.ActiveNode = itemColor;

itemColor = new ColorWithHighlights(Color.LightBlue, 48);
itemColors.ClearWindowInset = itemColor;




If you can make some sense of it, this will probably help you most and fastest.

If you can’t make sense of the code, take a look at this sub-forum
https://www.elvastower.com/forums/index.php?/forum/401-or-translations-questions-feedback/
at Elvas Tower. Many questions, not only regarding "how to translate this and that" problems, have
already been answered.

If that still doesn’t help, simply ask, either in the public forums (most likely to get a useful answer), or
somehow else (Private Messages or emails to your translation tutor or other translators, etc.).

Miscellaneous Notes
If you have any problems, feel free to contact the team on the Elvas Tower forums (
https://www.elvastower.com/ ), where a bunch of info can already be found with a search as well.

If you are having problems with this tutorial, contact the updater (see end of file).
Be prepared that translating is a tedious process that takes time and effort and is not always fun. But in

the end, it may well be worth it, helping to make ORTS enjoyable also for people who have no
knowledge of other languages already available as translations.

Original document contributed by Markus Gelbmann
Please send feedback and corrections to Chris@Jakeman.plus.com


https://www.elvastower.com/forums/index.php?/forum/401-or-translations-questions-feedback/%20%20
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